Hacker News new | past | comments | ask | show | jobs | submit login
Starting Apr 2022, all apps submitted must be built with Xcode13 and iOS15 SDK (developer.apple.com)
35 points by BigBalli 7 days ago | hide | past | favorite | 6 comments





Is it just me or is Xcode one of the worst IDEs going? I mostly use AppCode, but will begrudgingly jump into Xcode to adjust schemes, debug memory leaks, add image assets, etc. But it is a truly awful piece of software. It seems that with every year, Apple fails to improve Xcode in any meaningful way.

Does this mean something for Zig crosscompilation? Like something mentioned here:

https://zig.news/kristoff/cross-compile-a-c-c-project-with-z...


To use Xcode13 you also need a recent Mac OS version.

And pray daily to Apple church.

I'm using Xcode 13 beta on a 2012 MacBook Pro, it works just fine.

glad to see the walled garden getting new walls



Guidelines | FAQ | Lists | API | Security | Legal | Apply to YC | Contact

Search: