Hacker News new | past | comments | ask | show | jobs | submit login

  running_avg
  where 
     sum = first(input) fby sum + next(input);
     n = 1 fby n + 1;
     running_avg = sum / n;
  end;
So if you change the name of the function, you have to change it everywhere inside its body? I'm not sure if I like that.



That's generally the way recursion works too. Do you have similar issues with it?

IDEs have largely made this a solved problem anyway.


Yes. Though I guess you could always wrap it up.




Guidelines | FAQ | Lists | API | Security | Legal | Apply to YC | Contact

Search: