- "isgoodtime" is a magic variable that changes depending on when it is imported. It should therefore be either a function or method on an object.
- "if isgoodtime == True" should be "if isgoodtime:" (although this would probably change to "if isgoodtime():"
- words in functions should be separated by underscores, e.g., is_good_time, to_great_content
Also, I'm just terrible at writing code. See previous post on tommy.authpad.com
Sorry for being a pedant :)