Hacker News new | comments | show | ask | jobs | submit login

It looks perfect in Firefox and Chrome and IE and locally, for me. The slightest of banding on the tab, now I come to look for it. I guess you're using a browser that doesn't render animated GIFs very well.

I tested on Chrome 23, Firefox 15 and Safari 6 on Mac OS X. All the same result.

Edit: looks the same in Photoshop too: http://i.imgur.com/nu90E.png

That's really interesting. I'm on Windows 7. Just tested in Debian Linux and it's fine there too. Must be a Mac issue?

(Edit: I confirm that I can see faint green spots all over the background in your Photoshop screenshot.)

Likely. I remembered OSX used to have few issues with GIF rendering in Core Graphics, but I'm sure Chrome and Firefox aren't using Core Graphics for GIF rendering. Strange.

I have the same issue as sirn on Firefox on Win7. edit: also chrome and IE.

Just a thought - are you in True Color (32-bit) mode?

Yes. I'm guessing gamma is to blame here.

Looks fine in FF on my MBP!

Could it be just because we've got our monitors set to different gammas? Here's a frame from the animated gif, which still looks fine to me: https://picasaweb.google.com/lh/photo/oaNDcnogej-bbrArcXuzK9...

Does this look dithered to anyone?

This one looks good to me. Animated gif, on the other hand, does look dithered on its background. Ubuntu 12.04, Chromium 18.0.1025.168.

This one looks perfectly fine to me. Gamma 2.2 (Mountain Lion default).

OK. Well I guess this supports the original poster's motivation, that animated GIFs can't be relied on.

Looks fine in Chrome on my MBA as well.

Guidelines | FAQ | Support | API | Security | Lists | Bookmarklet | DMCA | Apply to YC | Contact