Hacker News new | past | comments | ask | show | jobs | submit login

'Underscore.m' seems a lot nicer to me: http://underscorem.org/

I mean, what?

  N* value = (N*) hash.getOrAdd(l, ^{ return N.I(0); });
I'll take a minor increase in verbosity for a massive increase in readability in the future.

(edited; unwrapping is needed in both libraries)




Agreed, I hadn't seen this library before.


fwiw, I do like seeing a variety of libraries - they occasionally come to the same kind behavior through different techniques. It's a fun way to get a deeper knowledge of the language.




Guidelines | FAQ | Lists | API | Security | Legal | Apply to YC | Contact

Search: