Hacker News new | comments | show | ask | jobs | submit login

I had ruby - I was missing the ruby-dev header files.

My original complaint though is that people are using "gem install" as the sole documentation for installing a general purpose command-line tool. I'd rather not even know it's written in Ruby (I just want to install it and use it) - instead, I need deep Ruby knowledge just to get the thing running.




I hate that it's using gem for install, too.


If knowing how to type "yum install ruby-devel" qualifies as "deep Ruby knowledge", I must be some kind of god.




Guidelines | FAQ | Support | API | Security | Lists | Bookmarklet | DMCA | Apply to YC | Contact

Search: