Hacker News new | comments | show | ask | jobs | submit login

That's a shame - this is my main complaint about bootstrap. If you do plunge ahead and do a bunch of color customization, it also makes upgrading to new versions a pain.



I didn't even notice the LESS variables and built a dark theme in about 20 minutes by cascading over Bootstrap vanilla. Upgrading isn't an issue as long as you make customizations in a separate file that you simply include after bootstrap.css.

http://danneu.com/darkstrap/darkstrap.html


Actually, to give credit where it's due, I just downloaded the 2.0 release and it seems like things are much better. Still not at the point I'm describing, but at least the end classes aren't littered with @gray declarations.




Guidelines | FAQ | Support | API | Security | Lists | Bookmarklet | DMCA | Apply to YC | Contact

Search: