Hacker News new | past | comments | ask | show | jobs | submit login

I just upgraded an app from 3.0.7 to 3.1.0 rc1

I use Devise and Mongo Mapper. The Mongo Mapper for Devise gem depends on Devise 1.1.x, and this causes a bunch of deprecation warnings, but it works. I don't know if the latest Devise has this fixed, as I can't run it due to the Mongo Mapper for Devise dependency.

Some hand editing of development.rb to remove the debug_rjs setting and some editing to change my use of stylesheet_tag and my app ran ok

I'm not using the cool new asset pipeline yet, but my app runs with 1 hour of work.




Did you just point the gemfile to newer version and did hand editing as you went along or is there a command for the upgrade?


I've had trouble with Mongo Mapper and Devise.

I've upgraded Mongo Mapper to 0.9.1 to take advantage of it's Rails 3 integration, and it works with Devise 1.3.4 which removes the deprecation warnings.

To do this, I had to pull down the devise-mongo_mapper plugin to avoid version conflicts - it works with the newer code with no changes.

Mongo Mapper 0.9.x has a new configuration hookup that I had already written myself, so that code had to get a small change.

Joint, a Mongo Mapper plugin, doesn't work. I was going to replace Joint anyway for my own needs, now I need to do it today instead of next week.

Now I'm 2 hours in, and still not working on the Asset pipeline work I want to do, but my app is running except for the Joint bits


I just manually changed the Gemfile to 3.1.0.rc1 and fixed things that broke.

My next step is to fixup my morass of CSS and JS files to use the Asset pipeline correctly. That's probably another hour or so.




Guidelines | FAQ | Support | API | Security | Lists | Bookmarklet | Legal | Apply to YC | Contact

Search: