Hacker News new | past | comments | ask | show | jobs | submit login

Great - can't wait to try out the new version! I am running fast.ai in a virtual environment. How does one upgrade to the latest version for both Fast.ai and PyTorch. Are the new versions backwards comaptible with the earlier version - would it break any code? If not, would you recommend I clone the current install and upgrade that to be on the safe side. Thanks!



None of fastai is backwards compatible with v0.7 - although the API has a similar structure, so it shouldn't be hard to rewrite. PyTorch v1.0 also has some big differences to the version we used in the course.

I suggest you create a new conda environment and then follow the instructions in the readme to install both.




Guidelines | FAQ | Support | API | Security | Lists | Bookmarklet | Legal | Apply to YC | Contact

Search: