Hacker News new | comments | ask | show | jobs | submit login

In addition, Fabric doesn't support Python 3. The feedback I've gotten back on when Python 3 will be supported and how much of the legacy fabric API's will be supported is even more limited.

There is a fork with Python 3 support: https://github.com/mathiasertl/fabric/

If you use fabtools, I maintain a fork of it for fabric3: https://github.com/develtech/fabtools/tree/fabric3




I use your fork, thank you for your work!


Yeah, the fabric3 fork works really well.

Also, the fabric author has been making a lot of progress on Fabric 2, which works on Python 3.

https://github.com/fabric/fabric/tree/v2




Applications are open for YC Summer 2019

Guidelines | FAQ | Support | API | Security | Lists | Bookmarklet | Legal | Apply to YC | Contact

Search: