Hacker News new | past | comments | ask | show | jobs | submit login

Mozilla can contribute to Firefox 57's success by finishing all the missing WebExtensions APIs. So many extensions are going to be impossible to recreate.



Help us! Write patches to dependencies of this bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1215059


Thanks for that link, now I can clearly see that from the power-user perspective WebExtensions is a dead-end. If you look at the RESOLVED WONTFIX issues linked in that bug, you will find a lot of them are rejected based on political reasons. For example: https://bugzilla.mozilla.org/show_bug.cgi?id=1246706

Listen, I don't care whether features that I need don't fit the WebExtensions security model or whether they are confusing to a clueless user. If you can't support these features as part of WebExtensions, please design a separate set of APIs. Fine with me if you market extensions targeting these lower-level APIs as "dangerous, use at your own risk".




Guidelines | FAQ | Support | API | Security | Lists | Bookmarklet | Legal | Apply to YC | Contact

Search: