Hacker News new | past | comments | ask | show | jobs | submit login

If you have release criteria, sure, bump to 1.0 when you hit them. But if you don't have release criteria, just name it 1.0 and go from there. Version numbers don't matter as much as people think they do. This way we can avoid people having to type "0.7", "0.8" etc for 17 years instead of just "7" and "8".



I have been an irssi user for almost 15 years and I don't remember having typed the version number even once. Indeed, it does not matter so much as some people think.




Applications are open for YC Winter 2020

Guidelines | FAQ | Support | API | Security | Lists | Bookmarklet | Legal | Apply to YC | Contact

Search: